Collaborative Science

Accelerating time to market and driving innovation with collaboration, knowledge based understanding and prediction.

System Requirements for Discovery Studio 2020

The following sections cover the system requirements for Discovery Studio:

Supported Operating Systems

Operating System

Architecture

Client

Server

Microsoft Windows 10 64 bit +
+*
Microsoft Windows 2012 R2 64 bit  
+
Microsoft Windows Server 2016 64 bit
+
Microsoft Windows Server 2019 64 bit
+
Red Hat Enterprise Linux v7 64 bit
+
+
CentOS 7 64 bit
+**
+

* The server has not been fully validated but there are no known issues reported when running in a single user environment. It is not recommended for multiple users.
** Preliminary testing done. Not fully validated.

Processor and RAM Requirements

Component

Minimum Hardware

Processor Intel-compatible x86_64 architecture
RAM
  • 4 GB per core
  • 16 GB for a single core processor

Note: Additional memory will increase performance.

Disk Space Requirements

The following table gives approximate space requirements for Discovery Studio. The databases are optional but provide additional capabilities when installed.

Module

Approximate Size

Discovery Studio Client 1 GB
Pipeline Pilot with Discovery Studio Collections 25 GB
Antibody Database (redundant structures) 4.4 GB
BLAST Database 0.5 GB
PharmaDB 5 GB

Supported Graphics Cards

The following graphics cards are supported for the client. Cards that are certified have been validated with Discovery Studio. Non-certified cards are expected to work with Discovery Studio, but have not been tested. See Supported Graphics Card Drivers below for a list of supported drivers.

Note:

  • Some ATI drivers are known to have problems when DS is run as an administrator (root).
  • Limited testing has been run on Intel graphics cards on Windows. Some of these cards do not support all features used by Discovery Studio. The Optimize Graphics Settings startup option will detect this and disable those features.

Graphics Card

Performance

Certified

Stereo Support

ATI FirePro V4900
mid
 
ATI FirePro V5900 mid  
ATI FirePro V7900 high    
AMD FirePro W5000 mid  
AMD FirePro W8000
high
+
AMD FirePro W2100
basic
  +
AMD FirePro W4100
mid
+
AMD FirePro W5100
mid
  +
AMD FirePro W7100
high
  +
AMD Radeon Pro WX4100
mid
   
AMD Radeon Pro WX5100
mid
   
AMD Radeon Pro WX7100
high
+ (Win) +
NVIDIA Quadro 600 basic    
NVIDIA Quadro K620 basic  
NVIDIA Quadro 2000/K2000 mid   + (Win)
NVIDIA Quadro K2200 mid +  
NVIDIA Quadro 4000/K4000 high   +
NVIDIA Quadro K5000 high   +
NVIDIA Quadro 6000 ultra high   +
NVIDIA Quadro M4000 mid   +
NVIDIA Quadro M5000 high + +
NVIDIA Quadro M6000 ultra high   +
NVIDIA Quadro P5000 ultra high + +

Supported Graphics Card Drivers

Operating System

ATI/AMD V-Series

ATI/AMD W-, WX- and Radeon Pro- Series

NVIDIA Quadro K and M- Series

Microsoft Windows 10
 
19.Q3 431.86
Red Hat 7 15.201.2401 19.Q3 (Red Hat 7.6 only) 430.40
CentOS 7     430.40

Supported Software for the Grid

Software Version


  • PBS Professional 18.2.3
  • SLURM 18.08

Additional Software Requirements

System Libraries (Linux)

Certain system libraries may be required for the correct operation of Discovery Studio. To automatically detect which libraries may be required for your system, run the check_system.sh script, available on the Discovery Studio distribution. For details, see Required System Libraries.

BLAST

The BLAST Search (Discovery Studio server) and PSI-BLAST Search protocols rely on a separately installed BLAST database. For more details regarding the extraction and installation of the BLAST database, see "Installing the BLAST database" in the Discovery Studio Installation Guide.

GNOME Desktop (Linux)

The Discovery Studio Client is optimized for the GNOME Desktop. We recommend that you install and configure this software, which is available on your Linux distribution media. Note that KDE Desktop is also supported.

CHARMm OpenMM GPU Requirements

Operating System

Operating System

Version

RedHat 7
CentOS 7

Graphics Cards and Drivers

The following combinations of NVIDIA graphics card, driver, and operating system are tested and certified for CHARMm OpenMM GPU:

Graphic Card

Driver Version

Operating System

Graphics Memory

GeForce GTX 1080 Ti NVIDIA 384.111 RedHat 7.4 11 GB
Quadro GP100 NVIDIA 390.129 CentOS 7.5 16 GB
Quadro P5000 NVIDIA 390.129 RedHat 7.5 16 GB
Quadro K2200 NVIDIA 390.129 RedHat 7.5 4 GB

Note:

  • CHARMmCHARMm is integrated with OpenMM 7.1.1, which depends on CUDA 8.0.61 and OpenCL 1.0.0 libraries. All of these libraries are included with the Discovery Studio server installation.
  • CHARMm DOMDEC supports CUDA 8, but does not support OpenCL.
  • Graphics cards not listed above that are compatible with CUDA 8 are expected to work. Graphics cards incompatible with CUDA 8 are not supported.
  • The minimum graphics driver version for CUDA 8.0.61 is NVIDIA 375.26. Newer driver versions are expected to work but those not listed in the table above have not been tested.